Enable -fstack-protector-strong by default on x86