__GNUC_PREREQ should be causing problems anymore.