Update the oggopus script to use xml2rfc v2.
authorRalph Giles <giles@mozilla.com>
Wed, 19 Dec 2012 00:37:04 +0000 (16:37 -0800)
committerRalph Giles <giles@mozilla.com>
Wed, 19 Dec 2012 00:37:04 +0000 (16:37 -0800)
The command line has changed, for the better, but we need to
update the way we call it. Also adds an install hint if it's
not found on the path.

NB I tried to detect and fallback to the old syntax for the
version 1 (TCL) implementation but this is hard because it
doesn't support any switches (like --version) and it no
longer parses our remote entities.

doc/build_oggdraft.sh

index aa65aeb..30ee534 100755 (executable)
@@ -38,7 +38,15 @@ set -e
 #Set the CWD to the location of this script
 [ -n "${0%/*}" ] && cd "${0%/*}"
 
+if test -z `which xml2rfc 2> /dev/null`; then
+  echo "Error: couldn't find xml2rfc."
+  echo
+  echo "Please install xml2rfc version 2 or later."
+  echo "E.g. 'pip install xml2rfc' or follow the instructions"
+  echo "on http://pypi.python.org/pypi/xml2rfc/ or tools.ietf.org."
+  exit 1
+fi
+
 echo running xml2rfc
-xml2rfc draft-ietf-codec-oggopus.xml draft-ietf-codec-oggopus.html &
-xml2rfc draft-ietf-codec-oggopus.xml
-wait
+# version 2 syntax
+xml2rfc draft-ietf-codec-oggopus.xml --text --html