CMake changes
[opus.git] / OpusConfig.cmake.in
1 set(OPUS_VERSION @PROJECT_VERSION@)
2 set(OPUS_VERSION_STRING @PROJECT_VERSION@)
3 set(OPUS_VERSION_MAJOR @PROJECT_VERSION_MAJOR@)
4 set(OPUS_VERSION_MINOR @PROJECT_VERSION_MINOR@)
5 set(OPUS_VERSION_PATCH @PROJECT_VERSION_PATCH@)
6
7 @PACKAGE_INIT@
8
9 set_and_check(OPUS_INCLUDE_DIR "@PACKAGE_INCLUDE_INSTALL_DIR@")
10 set_and_check(OPUS_INCLUDE_DIRS "@PACKAGE_INCLUDE_INSTALL_DIR@")
11
12 include(${CMAKE_CURRENT_LIST_DIR}/OpusTargets.cmake)
13
14 set(OPUS_LIBRARY Opus::opus)
15 set(OPUS_LIBRARIES Opus::opus)
16
17 check_required_components(Opus)
18
19 set(OPUS_FOUND 1)