Fixes ope_encoder_drain() bug
[libopusenc.git] / Makefile.am
1 ACLOCAL_AMFLAGS = -I m4
2
3 DEFS += -DSPX_RESAMPLE_EXPORT= -DRANDOM_PREFIX=libopusenc -DOUTSIDE_SPEEX -DFLOATING_POINT
4
5 AM_CFLAGS = -I$(top_srcdir)/include $(DEPS_CFLAGS)
6
7 dist_doc_DATA = COPYING AUTHORS README.md
8
9 opusincludedir = ${includedir}/opus
10 opusinclude_HEADERS = include/opusenc.h
11
12 lib_LTLIBRARIES = libopusenc.la
13 noinst_HEADERS = src/arch.h \
14                  src/ogg_packer.h \
15                  src/opus_header.h \
16                  src/picture.h \
17                  src/resample_sse.h \
18                  src/speex_resampler.h \
19                  src/stack_alloc.h \
20                  src/unicode_support.h
21
22 libopusenc_la_SOURCES = \
23         src/ogg_packer.c \
24         src/opus_header.c \
25         src/opusenc.c \
26         src/picture.c \
27         src/resample.c \
28         src/unicode_support.c
29 libopusenc_la_LIBADD = $(DEPS_LIBS) $(lrintf_lib)
30 libopusenc_la_LDFLAGS = -no-undefined \
31  -version-info @OP_LT_CURRENT@:@OP_LT_REVISION@:@OP_LT_AGE@
32
33 if OP_ENABLE_EXAMPLES
34 noinst_PROGRAMS = examples/opusenc_example
35 endif
36
37 examples_opusenc_example_SOURCES = examples/opusenc_example.c
38 examples_opusenc_example_LDADD = libopusenc.la
39
40 pkgconfigdir = $(libdir)/pkgconfig
41 pkgconfig_DATA = libopusenc.pc
42
43 debug:
44         $(MAKE) CFLAGS="${CFLAGS} -O0 -ggdb -DOP_ENABLE_ASSERTIONS" all
45
46 EXTRA_DIST = \
47  libopusenc.pc.in \
48  libopusenc-uninstalled.pc.in \
49  doc/Doxyfile.in \
50  doc/opus_logo.svg \
51  doc/Makefile
52
53 # Targets to build and install just the library without the docs
54 libopusenc install-libopusenc: NO_DOXYGEN = 1
55
56 libopusenc: all
57 install-libopusenc: install
58
59 # Or just the docs
60 docs: doc/doxygen-build.stamp
61
62 install-docs:
63         @if [ -z "$(NO_DOXYGEN)" ]; then \
64           ( cd doc && \
65             echo "Installing documentation in $(DESTDIR)$(docdir)"; \
66             $(INSTALL) -d $(DESTDIR)$(docdir)/html/search; \
67             for f in `find html -type f \! -name "installdox"` ; do \
68               $(INSTALL_DATA) $$f $(DESTDIR)$(docdir)/$$f;     \
69             done ) \
70         fi
71
72 doc/doxygen-build.stamp: doc/Doxyfile $(top_srcdir)/doc/opus_logo.svg \
73                          $(top_srcdir)/include/*.h
74         @[ -n "$(NO_DOXYGEN)" ] || ( cd doc && doxygen && touch $(@F) )
75
76
77 if HAVE_DOXYGEN
78
79 # Or everything (by default)
80 all-local: docs
81
82 install-data-local: install-docs
83
84 clean-local:
85         $(RM) -r doc/html
86         $(RM) -r doc/latex
87         $(RM) doc/doxygen-build.stamp
88
89 uninstall-local:
90         $(RM) -r $(DESTDIR)$(docdir)/html
91
92 endif
93
94 # We check this every time make is run, with configure.ac being touched to
95 # trigger an update of the build system files if update_version changes the
96 # current PACKAGE_VERSION (or if package_version was modified manually by a
97 # user with either AUTO_UPDATE=no or no update_version script present - the
98 # latter being the normal case for tarball releases).
99 #
100 # We can't just add the package_version file to CONFIGURE_DEPENDENCIES since
101 # simply running autoconf will not actually regenerate configure for us when
102 # the content of that file changes (due to autoconf dependency checking not
103 # knowing about that without us creating yet another file for it to include).
104 #
105 # The MAKECMDGOALS check is a gnu-make'ism, but will degrade 'gracefully' for
106 # makes that don't support it.  The only loss of functionality is not forcing
107 # an update of package_version for `make dist` if AUTO_UPDATE=no, but that is
108 # unlikely to be a real problem for any real user.
109 $(top_srcdir)/configure.ac: force
110         @case "$(MAKECMDGOALS)" in \
111             dist-hook)                             exit 0       ;; \
112             dist-* | dist | distcheck | distclean) _arg=release ;; \
113         esac; \
114         if ! $(top_srcdir)/update_version $$_arg 2> /dev/null; then \
115             if [ ! -e $(top_srcdir)/package_version ]; then \
116                 echo 'PACKAGE_VERSION="unknown"' > $(top_srcdir)/package_version; \
117             fi; \
118             . $(top_srcdir)/package_version || exit 1; \
119             [ "$(PACKAGE_VERSION)" != "$$PACKAGE_VERSION" ] || exit 0; \
120         fi; \
121         touch $@
122
123 force:
124
125 # Create a minimal package_version file when make dist is run.
126 dist-hook:
127         echo 'PACKAGE_VERSION="$(PACKAGE_VERSION)"' > $(top_distdir)/package_version
128
129
130 .PHONY: libopusenc install-libopusenc docs install-docs