Apparently the tar compatibility option has compatibility problems!