Update Opus range coder due to CELT refactoring.
[opus.git] / autogen.sh
1 #!/bin/sh
2 # Run this to set up the build system: configure, makefiles, etc.
3 # (based on the version in enlightenment's cvs)
4
5 package="ietfcodec"
6
7 olddir=`pwd`
8 srcdir=`dirname $0`
9 test -z "$srcdir" && srcdir=.
10
11 cd "$srcdir"
12 DIE=0
13
14 echo "autogeh in celt"
15 (cd celt; ./autogen.sh)
16 echo "autogeh in silk"
17 (cd silk; ./autogen.sh)
18
19 echo "checking for autoconf... "
20 (autoconf --version) < /dev/null > /dev/null 2>&1 || {
21         echo
22         echo "You must have autoconf installed to compile $package."
23         echo "Download the appropriate package for your distribution,"
24         echo "or get the source tarball at ftp://ftp.gnu.org/pub/gnu/"
25         DIE=1
26 }
27
28 VERSIONGREP="sed -e s/.*[^0-9\.]\([0-9]\.[0-9]*\).*/\1/"
29 VERSIONMKINT="sed -e s/[^0-9]//"
30                                                                                 
31 # do we need automake?
32 if test -r Makefile.am; then
33   AM_NEEDED=`fgrep AUTOMAKE_OPTIONS Makefile.am | $VERSIONGREP`
34   if test -z $AM_NEEDED; then
35     echo -n "checking for automake... "
36     AUTOMAKE=automake
37     ACLOCAL=aclocal
38     if ($AUTOMAKE --version < /dev/null > /dev/null 2>&1); then
39       echo "yes"
40     else
41       echo "no"
42       AUTOMAKE=
43     fi
44   else
45     echo -n "checking for automake $AM_NEEDED or later... "
46     for am in automake-$AM_NEEDED automake$AM_NEEDED automake; do
47       ($am --version < /dev/null > /dev/null 2>&1) || continue
48       ver=`$am --version < /dev/null | head -n 1 | $VERSIONGREP | $VERSIONMKINT`
49       verneeded=`echo $AM_NEEDED | $VERSIONMKINT`
50       if test $ver -ge $verneeded; then
51         AUTOMAKE=$am
52         echo $AUTOMAKE
53         break
54       fi
55     done
56     test -z $AUTOMAKE &&  echo "no"
57     echo -n "checking for aclocal $AM_NEEDED or later... "
58     for ac in aclocal-$AM_NEEDED aclocal$AM_NEEDED aclocal; do
59       ($ac --version < /dev/null > /dev/null 2>&1) || continue
60       ver=`$ac --version < /dev/null | head -n 1 | $VERSIONGREP | $VERSIONMKINT`
61       verneeded=`echo $AM_NEEDED | $VERSIONMKINT`
62       if test $ver -ge $verneeded; then
63         ACLOCAL=$ac
64         echo $ACLOCAL
65         break
66       fi
67     done
68     test -z $ACLOCAL && echo "no"
69   fi
70   test -z $AUTOMAKE || test -z $ACLOCAL && {
71         echo
72         echo "You must have automake installed to compile $package."
73         echo "Download the appropriate package for your distribution,"
74         echo "or get the source tarball at ftp://ftp.gnu.org/pub/gnu/"
75         exit 1
76   }
77 fi
78
79 echo -n "checking for libtool... "
80 for LIBTOOLIZE in libtoolize glibtoolize nope; do
81   ($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1 && break
82 done
83 if test x$LIBTOOLIZE = xnope; then
84   echo "nope."
85   LIBTOOLIZE=libtoolize
86 else
87   echo $LIBTOOLIZE
88 fi
89 ($LIBTOOLIZE --version) < /dev/null > /dev/null 2>&1 || {
90         echo
91         echo "You must have libtool installed to compile $package."
92         echo "Download the appropriate package for your system,"
93         echo "or get the source from one of the GNU ftp sites"
94         echo "listed in http://www.gnu.org/order/ftp.html"
95         DIE=1
96 }
97
98 if test "$DIE" -eq 1; then
99         exit 1
100 fi
101
102 echo "Generating configuration files for $package, please wait...."
103
104 echo "  $ACLOCAL $ACLOCAL_FLAGS"
105 $ACLOCAL $ACLOCAL_FLAGS || exit 1
106 #echo "  autoheader"
107 #autoheader || exit 1
108 echo "  $LIBTOOLIZE --automake"
109 $LIBTOOLIZE --automake || exit 1
110 echo "  $AUTOMAKE --add-missing $AUTOMAKE_FLAGS"
111 $AUTOMAKE --add-missing $AUTOMAKE_FLAGS || exit 1
112 echo "  autoconf"
113 autoconf || exit 1
114
115 cd $olddir
116 #$srcdir/configure "$@" && echo