cmake/configure.ac: Enable -fstack-protector-strong by default