sync with 1.0.2