CMake minimum required lowered to 3.1