update version number to 1.0.1; minor cosmetics with Ogg defines
authorJosh Coalson <jcoalson@users.sourceforce.net>
Sun, 11 Nov 2001 03:59:46 +0000 (03:59 +0000)
committerJosh Coalson <jcoalson@users.sourceforce.net>
Sun, 11 Nov 2001 03:59:46 +0000 (03:59 +0000)
configure.in

index 52a25d6..722699a 100644 (file)
@@ -19,7 +19,7 @@
 # instead of FLAC__ since autoconf triggers off 'AC_' in strings
 
 AC_INIT(src/flac/main.c)
-AM_INIT_AUTOMAKE(flac, 1.0)
+AM_INIT_AUTOMAKE(flac, 1.0.1)
 
 # We need two libtools, one that builds both shared and static, and
 # one that builds only static.  This is because the resulting libtool
@@ -79,7 +79,10 @@ fi
 AC_CHECK_LIB(ogg, ogg_stream_init,
              [LIBS="$LIBS -logg"; have_ogg=yes],
              [AC_MSG_WARN([*** Ogg development enviroment not installed - ogg support will not be built])])
-AM_CONDITIONAL(FLaC__HAS_OGG, [test $have_ogg = xyes])
+AM_CONDITIONAL(FLaC__HAS_OGG, [test x$have_ogg = xyes])
+if test x$have_ogg = xyes ; then
+AC_DEFINE(FLAC__HAS_OGG)
+fi
 
 AM_PATH_XMMS(0.9.5.1, , AC_MSG_WARN([*** XMMS >= 0.9.5.1 not installed - xmms support will not be built]))
 AM_CONDITIONAL(FLaC__HAS_XMMS, test x$XMMS_INPUT_PLUGIN_DIR != x)