update links to 1.1.1 release
[flac.git] / README
diff --git a/README b/README
index a0e3e92..8af4975 100644 (file)
--- a/README
+++ b/README
@@ -1,5 +1,5 @@
 /* FLAC - Free Lossless Audio Codec
- * Copyright (C) 2001,2002,2003  Josh Coalson
+ * Copyright (C) 2001,2002,2003,2004  Josh Coalson
  *
  * This file is part the FLAC project.  FLAC is comprised of several
  * components distributed under difference licenses.  The codec libraries
@@ -27,7 +27,8 @@ FLAC is comprised of
   * `libOggFLAC' and `libOggFLAC++', which provide encoders and
     decoders for FLAC streams in an Ogg container
   * `flac', a command-line program for encoding and decoding files
-  * `metaflac', a command-line program for editing FLAC metadata
+  * `metaflac', a command-line program for viewing and editing FLAC
+    metadata
   * player plugins for XMMS and Winamp
   * user and API documentation
 
@@ -39,7 +40,7 @@ Documentation License (see COPYING.FDL).
 
 
 ===============================================================================
-FLAC - 1.1.0 - Contents
+FLAC - 1.1.1 - Contents
 ===============================================================================
 
 - Introduction
@@ -56,7 +57,7 @@ Introduction
 
 This is the source release for the FLAC project.  See
 
-       doc/index.html
+       doc/html/index.html
 
 for full documentation.
 
@@ -177,8 +178,7 @@ binaries, statically linked (e.g. obj\release\bin\flac.exe).
 Everything will end up in the "obj" directory.  DLLs and .exe files
 are all that are needed and can be copied to an installation area and
 added to the PATH.  The plugins have to be copied to their appropriate
-place in the player area.  For Winamp2 this is <winamp2-dir>\Plugins
-and for Winamp3 this is <winamp3-dir>\Wacs.
+place in the player area.  For Winamp2 this is <winamp2-dir>\Plugins.
 
 By default the code is configured with Ogg support.  Before building FLAC
 you will need to get the Ogg source distribution
@@ -205,6 +205,15 @@ This will create everything and leave it in the build/ directory.
 Don't worry about the rest of the stuff that is in build/ or
 the stuff that was already there before building.
 
+The Project Builder project requires that you have libiconv and
+libogg in /sw, ala fink.  If you don't, you'll need to install
+them somewhere and change the path to them in the Library Paths
+section of several targets.
+
+It also assumes the CPU supports Altivec instructions.  If it does
+not, you will also have to add -DFLAC__NO_ASM to the CFLAGS in the
+libFLAC target.
+
 There currently is no install procedure; you will have to
 manually copy the tools to wherever you need them.