CMake minimum required lowered to 3.1
[flac.git] / doc / CMakeLists.txt
1 cmake_minimum_required(VERSION 3.1)
2 find_package(Doxygen)
3
4 if (NOT DOXYGEN_FOUND)
5     return()
6 endif()
7
8 option(BUILD_DOXYGEN "Enable API documentation building via Doxygen" ON)
9
10 if (NOT BUILD_DOXYGEN)
11     return()
12 endif()
13
14 set(DOXYGEN_HTML_FOOTER doxygen.footer.html)
15 set(DOXYGEN_GENERATE_TAGFILE FLAC.tag)
16
17 doxygen_add_docs(FLAC-doxygen
18     "${PROJECT_SOURCE_DIR}/include/FLAC"
19     "${PROJECT_SOURCE_DIR}/include/FLAC++")
20
21 add_subdirectory(html)
22
23 install(DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/html/"
24     DESTINATION "${CMAKE_INSTALL_DOCDIR}/html/api")